Sufia 3.3.0 released

We are pleased to announce the release of an updated gem,  Sufia 3.3.0.

  • Fix authorities deprecations
  • Fix deprecation on MailboxController
  • Blacklight 4.4.1/0 doesn’t work with Kaminari > 0.14.1 See projectblacklight/blacklight#614
  • Allow acts_as_follower to be 0.2.0 for Rails 4 support
  • Don’t run Blacklight and Hydra generator twice
  • Remove deprecation warning on Rails 4
  • Updating CONTRIBUTING.md as per Hydra v6.0.0
  • Use Cancan to authorize and validate single-use tokens
  • Add ImageMagick as a software requirement in the README.
  • Split SingleUseLinkController into the authenticated controller that creates links, and a viewer that handles retrieving content for token-bearing users
  • Remove explicit GenericFile references, and replace them with Rails magic
  • Refactor single-use links for style and clarity
  • Add more gems to the gemfile for running tests from the gem root
  • Add redis-server to the .travis.yml list of services
  • Fix typos in README.md

Thanks to Chris Beer, Justin Coyne, and Jessie Keck.

The current versions of all Hydra gems can be accessed through https://wiki.duraspace.org/display/hydra/Gems+and+documentation

This entry was posted in News, Software updates. Bookmark the permalink.